Editor TinyMCE 4.0 llega al core de WordPress 3.9

Andrew Ozz el responsable de mantener TinyMCE en WordPress anuncio que TinyMCE 4.0 ya está integrado en el core.

Esta actualización contiene algunos cambios importantes como:

  • Nuevo Interfaz Visual (UI) y API UI.
  • Nuevo tema.
  • Cambios en los eventos del sistema/API.
  • Mejor calidad de código, usabilidad y proceso de integración.
  • Más documentación.
  • Y otras mejoras que podrás notar cuando lo uses.

tinymce 4 en wordpress 3.9

Todos los plugins por defecto de TinyMCE han sido actualizados para hacerlos compatibles con la versión 4.0 de TinyMCE. Esto implica cambios relacionados con el API, por lo que los desarrolladores de plugins tendrán que esforzarse para actualizar sus plugins y que sean 100% compatibles.

Andrew Ozz ha listado tres grupos de plugins TinyMCE que han sido añadido por Plugins para WordPress.

  • Plugins personalizados creados especificamente para Plugins de WordPress. Si has desarrollado un plugin de este tipo lo mejor es que veas la guías de migración de 3.x a 4.0 y la documentación del API 4.0.
  • Plugins de WordPress que añaden opciones a TinyMCE necesitan ser actualizados para incluirse en la versión 4.0. La variable global de PHP $tinymce_version puede ser utilizado para determinar que cargar en función de la versión.
  • Mini-plugins que solo añaden botones a la barra de herramientas de TinyMCE. Estos trabajan de la misma forma que siempre.

Fuente: wptavern

1 Comentario

  1. La actualización carece de ciertas opciones básicas, que bien para un webmaster no son muy necesarias, pero para sus clientes si lo son; con ésto me refiero a la opción de styles que ha sido eliminada y con la cual podiamos crear estilos para tablas, etc.

Dejar respuesta

Please enter your comment!
Please enter your name here