Cómo saber si mis plugins son compatibles con diversas versiones de PHP

Por mil motivos, hay veces que nos vemos obligados a abandonar nuestro servidor y migrar a uno nuevo. Ya sea por falta de recursos, o bien por motivos económicos, es posible que, o bien migremos a uno con una versión de PHP inferior, o bien a uno con una versión de PHP superior a la nuestra. Los que ya llevamos siendo administradores de WordPress desde hace tiempo, esto nos provoca un pavor horrible. Muchos plugins de los que tienes activos en tu web, e incluso el tema, pueden dejar de funcionar debido a que no son compatibles con la versión de PHP del nuevo servidor.

En este artículo te muestro cómo podemos saber si los plugins que tengamos activos en nuestro sitio web desarrollado con WordPress son compatibles con la versión de PHP del nuevo servidor donde alojaremos nuestro proyecto. Es un proceso muy sencillo, simplemente nos ayudaremos de un plugin para WordPress. ¿Todo entendido? ¡Pues allá vamos!

Saber si mis plugins son compatibles con diversas versiones de PHP

Lo primero que tienes que hacer es instalar y activar el plugin PHP Compatibility Checker. Para ello, ve a la sección Plugins del backoffice de tu WordPress y selecciona la opción de Añadir Nuevo. En la página de Añadir Nuevo Plugin, busca el plugin que queremos instalar haciendo uso del campo de búsqueda que se sitúa en la parte superior derecha de la página.

Teclea el nombre del plugin (que como te hemos indicado es “PHP Compatibility Checker”) y presiona ENTER para iniciar la búsqueda. Si has seguido los pasos al pie de la letra, este plugin te debería aparecer como el primer resultado de la búsqueda. Instálalo y actívalo para poder utilizarlo.

Una vez activado, tendrás que ir a Herramientas > PHP Compability para poder comprobar si tus plugins son compatibles con distintas versiones de PHP.

Como puedes ver en la imagen de más arriba, el plugin nos da la opción de escanear los temas y plugins que tengamos activos en nuestro sitio web desarrollado con WordPress. Para ello, lo único que tenemos que hacer es escoger la versión de PHP en la que queremos testear nuestros plugins y tema y pulsar en el botón Scan site.

Pasados unos minutos, el plugin nos indicará si los plugins que tenemos instalados y nuestro tema son compatibles con la versión de PHP que hayamos escogido. En el caso contrario, podremos ver qué características del plugin, o bien del tema, no son compatibles con la versión PHP designada.

El plugin también nos da la opción de escanear TODOS los plugins que tengamos instalados (activos y no activos) y todos los temas que tengamos instalados también (activos y no activos). Lógicamente, el proceso de escaneo tardará más tiempo, pero el resultado será el mismo que en la anterior operación. Es decir, en un listado se nos mostrarán todos los plugins y todos los temas y se nos indicará si son compatibles o no con la versión que hayamos seleccionado.

Y hasta aquí nuestro artículo sómo saber si los plugins que tenemos instalados son compatibles con otras versiones de PHP. Espero que te haya gustado y, si te ha resultado útil, no dudes en compartirlo en redes sociales. ¡Nos leemos!

Icono: m. turan ercan